Username:    Password:        Click Here To Signup     Forgotten Password
Main Menu
Online
Members: 0

Guests: 25

164.132.x.x dilbertplus
164.132.x.x user
180.76.x.x lgsl
217.182.x.x forum
217.182.x.x forum
217.182.x.x forum
217.182.x.x forum
220.181.x.x forum
46.161.x.x forum
46.229.x.x forum
46.229.x.x forum
46.229.x.x forum
46.229.x.x dilbertplus
46.229.x.x forum
46.229.x.x forum
46.229.x.x forum
46.229.x.x dilbertplus
46.229.x.x forum
46.229.x.x forum
51.255.x.x guestbook
51.255.x.x forum
51.255.x.x forum
51.255.x.x lgsl
54.224.x.x forum
68.180.x.x forum

Last Seen

Dodgeitorelse Wed 21:14
adneycandy Mon 11:03
ESO2017 Fri 04:11
Marylee Jones Fri 02:36
Ericka Burke Fri 01:12

Newest Members

Forums
Soldat LGSL not working
Fronbuk
Sun Mar 01 2015, 11:53AM
Posts: 9
Joined: Sun Mar 01 2015, 11:46AM
Registered Member #8223
Hi there, I noticed that LGSL is not working with Soldat game, I've selected soldat query engine, game port by default is 23073 query (admin) port is the same as game which is 23073, i have added a exception to my firewall for that port both tcp and udp, and lgsl is still not showing any info about the server
Wussie
Mon Mar 02 2015, 02:48PM

Posts: 430
Joined: Sun Mar 22 2009, 06:53AM
Registered Member #4938
Hi
I can confirm that the Soldat protocol in LGSL is indeed working as designed and you can verify this by trying the server at 91.218.228.210:23074 with a query port of 23197UDP.

Note that by default q_port = c_port + 123, but some admins may not follow this general rule.
First thing you have to do is find out the real query port of the server you are trying to query, and then make sure you set it right in LGSL.
The wrong query port is the most common cause for "server offline".

Not working for you?
Don't forget to share the IP/ports of the offending server so that people can do tests and help you.
Oh, and if you're using a modified lgsl_protocol.php, make sure you disable the feed or it may NOT work!
Website
Fronbuk
Thu Apr 02 2015, 07:07AM
Posts: 9
Joined: Sun Mar 01 2015, 11:46AM
Registered Member #8223
You are right, the server IP you gave me is working, in that case why mine doesn't work? I tried to q port same as join port and then tried +123 you suggested, none are working and the server is online, is there something you need to set in the config? I have no port blocked

5.9.122.38:23073
Wussie
Thu Apr 02 2015, 04:38PM

Posts: 430
Joined: Sun Mar 22 2009, 06:53AM
Registered Member #4938
Are players able to connect to your server?
Is your server listed in the in-game server browser?

Check your server.ini for the following parameters:
Lobby_Register=1 [!] If your server should be in the lobby list or not.
ASE_Register=1 [!] Enables or disables registering of the server with the All Seeing Eye (enable for Windows only).


Not working for you?
Don't forget to share the IP/ports of the offending server so that people can do tests and help you.
Oh, and if you're using a modified lgsl_protocol.php, make sure you disable the feed or it may NOT work!
Website
Fronbuk
Fri Apr 03 2015, 05:45AM
Posts: 9
Joined: Sun Mar 01 2015, 11:46AM
Registered Member #8223
I can join the server, I can see server listed in the server browser, both Lobby and ASE are set to 1
Wussie
Fri Apr 03 2015, 08:00AM

Posts: 430
Joined: Sun Mar 22 2009, 06:53AM
Registered Member #4938
Then try setting the query port as 23073+123 in the server cfg, restart the server and see if LGSL can query the new port.

Not working for you?
Don't forget to share the IP/ports of the offending server so that people can do tests and help you.
Oh, and if you're using a modified lgsl_protocol.php, make sure you disable the feed or it may NOT work!
Website
Fronbuk
Fri Apr 03 2015, 08:51AM
Posts: 9
Joined: Sun Mar 01 2015, 11:46AM
Registered Member #8223
thing is, soldat does not have the option to set query port, it's just the game port i can change
Wussie
Sat Apr 04 2015, 03:32PM

Posts: 430
Joined: Sun Mar 22 2009, 06:53AM
Registered Member #4938
Then how do you explain that the default query port should be c_port+123 and yours seems to be different?

Try installing LGSL on the same physical machine as the gameserver and then see if it shows online. This way you can be sure no firewall gets in the way and all ports are open (yes, turn off the firewall).

Not working for you?
Don't forget to share the IP/ports of the offending server so that people can do tests and help you.
Oh, and if you're using a modified lgsl_protocol.php, make sure you disable the feed or it may NOT work!
Website
Fronbuk
Mon Apr 06 2015, 03:58AM
Posts: 9
Joined: Sun Mar 01 2015, 11:46AM
Registered Member #8223
LGSL and game server is already installed on the same machine
Wussie
Mon Apr 06 2015, 07:50AM

Posts: 430
Joined: Sun Mar 22 2009, 06:53AM
Registered Member #4938
In that case there must be something in your game installation that's preventing it from responding to LGSL's queries.
I have no way of knowing what that is.

Not working for you?
Don't forget to share the IP/ports of the offending server so that people can do tests and help you.
Oh, and if you're using a modified lgsl_protocol.php, make sure you disable the feed or it may NOT work!
Website
 

Jump:     Back to top


You are not logged in - Click Here To Signup

Username:    Password:   

Mini Buttons

.... © GreyCube.com - Richard Perry - Powered by e107.org