Username:    Password:        Click Here To Signup     Forgotten Password
Main Menu
Online
Members: 0

Guests: 13

178.255.x.x lgsl
46.229.x.x dilbertplus
46.229.x.x forum
46.229.x.x forum
46.229.x.x forum
46.229.x.x forum
46.229.x.x forum
46.229.x.x forum
46.229.x.x forum
46.4.x.x forum
5.255.x.x forum
54.234.x.x forum
78.46.x.x forum

Last Seen

mrstipfan Wed 19:48
Gagi2 Mon 16:30
EFiNST0RM Sun 15:39
85filip58 Sun 12:14
brlight Tue 04:18

Newest Members

Forums
Support for Joomla 1.5 legacy mode?
Grinse
Sat Jan 31 2009, 04:21AM
Guest Hi there,
I've got a problem with LGSL in combination with Joomla 1.5.9 in Legacy mode.
Whenever I activate the Legacy Mode LGSL shows up errors. The same configuration (just without legacy mode) and all works fine.
Unfortunetly I need the legacy mode because two needed components are not compatible to Joomla 1.5 in native mode.

So is there a way to get LGSL running in Joomla 1.5 with legacy mode enabled?

Thanks for the Help.
Grinse
Rich
Sat Jan 31 2009, 09:11AM
Posts: 1717
Joined: Wed Nov 26 2003, 04:30PM

I was not aware of a legacy mode, so have not tested it.

What are the error messages you are getting ?
Website
Sobsoft
Sat Jan 31 2009, 11:38PM
Guest Hello, All. Is there LGSL have for 1.0.x joomla version? If have please post the link on sobsoft@redeagle.ru. Thanks
Grinse
Sun Feb 01 2009, 06:17AM
Guest Now things seems to get funny. I tested LGSL on another project (both the same local webspace) and there it seems to work in legacy and in normal mode.

Ok I tested my page again and I figured out that the Problem seems to be between LGSL and Joomfish:
As long as I switch of the jdatabase Plugin all works fine. But when I enable it (the plugin is neccassary for the auto translation of some database entries) I get the error message mentioned later.

I'm using LGSL 5.0 for Joomla (the component and the module), Joomla 1.5.9, Community Builder 1.2, Joomfish 2.0.2 and a few other addons.

The error message:
Warning: mysql_real_escape_string() [function.mysql-real-escape-string]: Access denied for user 'ODBC'@'localhost' (using password: NO) in C:\Programme\xampp\htdocs\test1\components\com_lgsl\lgsl_files\lgsl_class.php on line 301

Warning: mysql_real_escape_string() [function.mysql-real-escape-string]: A link to the server could not be established in C:\Programme\xampp\htdocs\test1\components\com_lgsl\lgsl_files\lgsl_class.php on line 301

Warning: mysql_real_escape_string() [function.mysql-real-escape-string]: Access denied for user 'ODBC'@'localhost' (using password: NO) in C:\Programme\xampp\htdocs\test1\components\com_lgsl\lgsl_files\lgsl_class.php on line 302

Warning: mysql_real_escape_string() [function.mysql-real-escape-string]: A link to the server could not be established in C:\Programme\xampp\htdocs\test1\components\com_lgsl\lgsl_files\lgsl_class.php on line 302

Warning: mysql_query() [function.mysql-query]: Access denied for user 'ODBC'@'localhost' (using password: NO) in C:\Programme\xampp\htdocs\test1\components\com_lgsl\lgsl_files\lgsl_class.php on line 313

Warning: mysql_query() [function.mysql-query]: A link to the server could not be established in C:\Programme\xampp\htdocs\test1\components\com_lgsl\lgsl_files\lgsl_class.php on line 313
Access denied for user 'ODBC'@'localhost' (using password: NO)


I hope you can help me out.
Grinse
Anonymous
Sun Feb 01 2009, 06:28AM
Guest But I only get this error message when legacy mode is enabled and the above mentioned jdatabase plugin (it's part of Joomfish 2.0.2) is active.

In native mode there is no problem when jdatabase plugin is enabled. (also in legacy mode when this plugin is deactivated).

Unfortunately I need the legacy mode (as long as not all my needed addons are compatible to native mode) and I also wanna use Joomfish (because there are different customer groups, speaking different languages on my page).
Rich
Sun Feb 01 2009, 12:38PM
Posts: 1717
Joined: Wed Nov 26 2003, 04:30PM

With Joomla, LGSL expects an open connection to the Joomla database where the LGSL table exists.

Whats happening is one of your plugins is breaking that connection to read another database, which LGSL then assumes is the joomla database.

The way round this is to edit the lgsl_config.php and in the SQL section, put in your Joomla database details, and then LGSL will be able to re-connect to the correct database.
Website
Grinse
Wed Feb 04 2009, 06:48AM
Guest Yeahaw. Thank you, the problem is solved now.

Ok for all, who will eventually have the same pronblem, here are the corresponding lines that have to be changed:
/components/com_lgsl/lgsl_files/lgsl_config.php (line 129 - 133; Database settings):
$lgsl_config['db']['server'] = "localhost";
$lgsl_config['db']['user'] = "root";
$lgsl_config['db']['pass'] = "";
$lgsl_config['db']['db'] = "lgsl";
$lgsl_config['db']['table'] = "lgsl";


Thank you again for the help Rich

Grinse
SAPPER
Sat May 30 2009, 04:13PM
Posts: 7
Joined: Sat May 30 2009, 11:05AM
Registered Member #5128
Hello,

I have a the same problem but not getting errors on page... I have it install on one site, syopscp.com joomla 1.5X and it works fine. Installed on our main site and when I go to view it as a menu page I get a blank page. When I try the mod I also get a blank page. I have tried uninstalling and reinstalling many time with the same results. I have tried to edit the config file as stated below with no luck also changed the lgsl_config['feed']['method'] = X; also added whitelisting for DB/Domain still not luck ... any clues?

SAPPER
http://syops.com
Website
SAPPER
Sat May 30 2009, 04:41PM
Posts: 7
Joined: Sat May 30 2009, 11:05AM
Registered Member #5128
NVM, after re-reading all the help in the forums and "Troubleshooting" I inquired to my host and my site will only allow port 80, so I'm guessing that is the issue.. The one site that it works on is hosted at siteground and the one that does not work is hosted with hostmysite for future info.

SAPPER
http://syops.com
Website
 

Jump:     Back to top


You are not logged in - Click Here To Signup

Username:    Password:   

Mini Buttons

.... © GreyCube.com - Richard Perry - Powered by e107.org