Username:    Password:        Click Here To Signup     Forgotten Password
Main Menu
Online
Members: 0

Guests: 15

146.185.x.x forum
180.76.x.x forum
180.76.x.x forum
46.229.x.x forum
46.229.x.x forum
46.229.x.x forum
46.229.x.x forum
46.229.x.x forum
46.229.x.x forum
46.229.x.x forum
46.229.x.x forum
46.229.x.x forum
46.229.x.x user
54.198.x.x forum
68.180.x.x forum

Last Seen

Dodgeitorelse Wed 21:08
Wussie Wed 15:58
iiiamirrr Mon 05:48
beshureinme Fri 14:51
goldfishes Fri 23:52

Newest Members

Forums
Richard Perry - GreyCube.com :: Forums :: Live Game Server List
Go to page   <<        >>     
Cool: Dynamic Server Image for LGSL
KIKOFF
Thu Nov 25 2010, 09:46PM

Posts: 132
Joined: Thu Nov 18 2010, 08:18AM
Registered Member #6411
No hay de que Bigfoot

Lo cortez, no quita lo valiente... ahhh... yes e107 Rock
Bigfoot
Thu Nov 25 2010, 09:49PM
Posts: 15
Joined: Wed Aug 19 2009, 03:40PM
Registered Member #5359
Well now i must integrate on servers details. And for some reason i have the same problem of Kikoff. Why maps images are not showing? :S
Website
KIKOFF
Fri Nov 26 2010, 08:31AM

Posts: 132
Joined: Thu Nov 18 2010, 08:18AM
Registered Member #6411
I think this thread is dead. Without support and those who know they have better things to do

Lo cortez, no quita lo valiente... ahhh... yes e107 Rock
Bigfoot
Fri Nov 26 2010, 11:02AM
Posts: 15
Joined: Wed Aug 19 2009, 03:40PM
Registered Member #5359
I going to ask this to a friend He is a great codder of Php Fusion
Website
KIKOFF
Fri Nov 26 2010, 12:32PM

Posts: 132
Joined: Thu Nov 18 2010, 08:18AM
Registered Member #6411
Bigfoot wrote ...

I going to ask this to a friend He is a great codder of Php Fusion

Nice...
Muchas gracias

Lo cortez, no quita lo valiente... ahhh... yes e107 Rock
dutchbastard
Sat Nov 27 2010, 08:19AM
Posts: 19
Joined: Mon Jan 25 2010, 11:53AM
Registered Member #5749
Here's the modified details.php page I had on my computer.
http://www.mediafire.com/?4cn48wahk4m20x3

It seems the main difference is at the bottom
//------------------------------------------------------------------------------------------------------------+
  
  $output .= "
    <table cellpadding='4' cellspacing='2' style='margin:auto'>
      <tr style='".lgsl_bg(TRUE)."' align='center'>
        <td><b>Banner</b></td>
        <td><img src='lgsl_files/lgsl_image.php?s=".$_GET['s']."'/></td>
      </tr>";
    
    $output .= "
      <tr style='".lgsl_bg(FALSE)."' align='center'>
        <td><b>Codes</b></td>
        <td><input type='text' readonly='readonly' size='55' onclick='select()' value='[url=http://".$_SERVER['HTTP_HOST'].$_SERVER['REQUEST_URI']."][img]http://".implode('/', (explode('/', $_SERVER['HTTP_HOST'].$_SERVER['REQUEST_URI'], -1)))."/lgsl_files/lgsl_image.php?s=".$_GET['s']."[/img][/url]' /><br />
        <input type='text' readonly='readonly' size='55' onclick='select()' value='[url=\"http://".$_SERVER['HTTP_HOST'].$_SERVER['REQUEST_URI']."\"][img]http://".implode('/', (explode('/', $_SERVER['HTTP_HOST'].$_SERVER['REQUEST_URI'], -1)))."/lgsl_files/lgsl_image.php?s=".$_GET['s']."[/img][/url]' /><br />
        <input type='text' readonly='readonly' size='55' onclick='select()' value='<a href=\"http://".$_SERVER['HTTP_HOST'].$_SERVER['REQUEST_URI']."\" target=\"_blank\" ><img src=\"http://".implode('/', (explode('/', $_SERVER['HTTP_HOST'].$_SERVER['REQUEST_URI'], -1)))."/lgsl_files/lgsl_image.php?s=".$_GET['s']."\" /></a>' />
        </td>
      </tr>";
      
    $output .= "
      <tr style='".lgsl_bg(TRUE)."' align='center'>
        <td><b>Banner</b></td>
        <td><img src='lgsl_files/lgsl_image.php?s=".$_GET['s']."&type=small'/></td>
      </tr>";
      
    $output .= "
      <tr style='".lgsl_bg(FALSE)."' align='center'>
       <td><b>Codes</b></td>
        <td><input type='text' readonly='readonly' size='55' onclick='select()' value='[url=http://".$_SERVER['HTTP_HOST'].$_SERVER['REQUEST_URI']."][img]http://".implode('/', (explode('/', $_SERVER['HTTP_HOST'].$_SERVER['REQUEST_URI'], -1)))."/lgsl_files/lgsl_image.php?s=".$_GET['s']."&type=small[/img][/url]' /><br />
        <input type='text' readonly='readonly' size='55' onclick='select()' value='[url=\"http://".$_SERVER['HTTP_HOST'].$_SERVER['REQUEST_URI']."\"][img]http://".implode('/', (explode('/', $_SERVER['HTTP_HOST'].$_SERVER['REQUEST_URI'], -1)))."/lgsl_files/lgsl_image.php?s=".$_GET['s']."&type=small[/img][/url]' /><br />
        <input type='text' readonly='readonly' size='55' onclick='select()' value='<a href=\"http://".$_SERVER['HTTP_HOST'].$_SERVER['REQUEST_URI']."\" target=\"_blank\" ><img src=\"http://".implode('/', (explode('/', $_SERVER['HTTP_HOST'].$_SERVER['REQUEST_URI'], -1)))."/lgsl_files/lgsl_image.php?s=".$_GET['s']."$type=small\" /></a>' />
       </td>  
      </tr>";
      
    $output .= "
      <tr style='".lgsl_bg(TRUE)."' align='center'>
        <td><b>Banner</b></td>
        <td><img src='lgsl_files/lgsl_image.php?s=".$_GET['s']."&type=sky'/></td>
      </tr>";
      
    $output .= "
      <tr style='".lgsl_bg(FALSE)."' align='center'>
        <td><b>Codes</b></td>
        <td><input type='text' readonly='readonly' size='55' onclick='select()' value='[url=http://".$_SERVER['HTTP_HOST'].$_SERVER['REQUEST_URI']."][img]http://".implode('/', (explode('/', $_SERVER['HTTP_HOST'].$_SERVER['REQUEST_URI'], -1)))."/lgsl_files/lgsl_image.php?s=".$_GET['s']."&type=sky[/img][/url]' /><br />
        <input type='text' readonly='readonly' size='55' onclick='select()' value='[url=\"http://".$_SERVER['HTTP_HOST'].$_SERVER['REQUEST_URI']."\"][img]http://".implode('/', (explode('/', $_SERVER['HTTP_HOST'].$_SERVER['REQUEST_URI'], -1)))."/lgsl_files/lgsl_image.php?s=".$_GET['s']."&type=sky[/img][/url]' /><br />
        <input type='text' readonly='readonly' size='55' onclick='select()' value='<a href=\"http://".$_SERVER['HTTP_HOST'].$_SERVER['REQUEST_URI']."\" target=\"_blank\" ><img src=\"http://".implode('/', (explode('/', $_SERVER['HTTP_HOST'].$_SERVER['REQUEST_URI'], -1)))."/lgsl_files/lgsl_image.php?s=".$_GET['s']."&type=sky\" /></a>' />
        </td>
      </tr>";
      
    $output .= "
    </table>";
  
//------------------------------------------------------------------------------------------------------------+

  $output .= "
  <div style='height:10px'><br /></div>
  <div style='".lgsl_bg(TRUE)."; width:90%; margin:auto; text-align:center; height:6px; border:1px solid'><br /></div>
  <div style='height:20px'><br /></div>";

  $output .= "
  </div>";  

//--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------+
Website
KIKOFF
Sat Nov 27 2010, 07:09PM

Posts: 132
Joined: Thu Nov 18 2010, 08:18AM
Registered Member #6411
Hi dutchbastard, this is not the problem, but thanks anyway.
As you can see the previous page, the flags and progress bar if displayed, but the map image and icon of the game, does not appear.

Lo cortez, no quita lo valiente... ahhh... yes e107 Rock
dutchbastard
Tue Nov 30 2010, 11:35AM
Posts: 19
Joined: Mon Jan 25 2010, 11:53AM
Registered Member #5749
yup indeed
I had the problem too
Weird really because it was working fine before

Anyway, in my lgsl_image.php there's this block of code
// Mapimage, Gameicon & Country
imagecopyresampled($im, $im_map, 10, 70, 0, 0, 160, 120, $im_map_info[0], $im_map_info[1]);
imagecopyresampled($im, $im_icon, $im_icon_posx, 73, 0, 0, $im_icon_width, $im_icon_height, $im_icon_info[0], $im_icon_info[1]);
if ($geoip==1){ imagecopyresampled($im, $cimage, $im_icon_posx + 120, 73, 0, 0, 16, 11, $cimage_info[0], $cimage_info[1]); }


Notice the 160, 120 in the first line
That first line originally looked like this for me:
imagecopyresampled($im, $im_map, $im_map_posx, $im_map_posy, 0, 0, $im_map_width, $im_map_height, $im_map_info[0], $im_map_info[1]);


When I changed $im_map_width, $im_map_height, to 160, 120 it showed up.
No idea why.
But maybe you have the same experience.
Website
MadMakz
Wed Dec 01 2010, 04:23PM

Posts: 163
Joined: Wed Sep 24 2008, 07:46AM
Registered Member #4406
Beside that i have moved to a new server, without caring to move the download area (and it's files including LGSL DSi) and that i've (actually thought that i) discontinued this "plugin" (which initially was ment to be a simple concept/example code without ever having support and turned out a little bigger at the end) some time ago,
I currently just can't up a new "official" mirror of the last release 'cause my PSU has burned and i just can't access the PC i have stored the files on. (No money to spend ~100€ for a new one atm)

To the recent issue above this post, i can only say that DSi worked fine with LGSL 5.8 including all features.

However, DSi and DSi-Detailspage Mod had never been coded or testetd against LGSL CMS (e107, Joomla, Drupal etc.) installations and so was also reported as broken for these types of installations on this forum!

Once my PC is running again at someday, i'll probably fix the quiet simple issue why it breaks on CMS installs.
Basically you just need to get the LGSL basepath/URI (perry somwhere posted the lgsl key containing that value) and integrate this into the imagepaths/URI's inside the DSi script.
I've never used/included this way since for the standalone install, i coded it for, the script simply works by using relative paths, on CMS installs we need an absolute path however. (or something like that, can't tell without seeing the DSi code infront)

Anyway, out of my mind and without having my code infront of me (due broken PC) i can't do anything atm.

Sorry!

Makz

EDIT: Must be a lucky day, i just see that i have a up2date backup on dropbox

Will reserve some time on friday and working out a fix then.

Download: http://community.cgx24.com/downloads.php?do=cat&id=3



SpiffyTek
Website
dutchbastard
Thu Dec 02 2010, 12:50PM
Posts: 19
Joined: Mon Jan 25 2010, 11:53AM
Registered Member #5749
thats a shame to hear about your pc I hope you get things worked out.
Thanks for posting the backup, I have my copy working fine now but I'm sure others can use it to their advantage.

With sourcepowered gone, does that also mean any tips and tricks preiously posted on its forums are gone as well?
The reason I ask is because I noticed you posted a link or 2 after people asked for advice, and since the links are dead, the advice is gone with it.
For example the link you posted on the top of the page before this one.

In any case, even though you never meant to gie any extensive support it seems you have done so in the past, so thanks again.
Website
MadMakz
Thu Dec 02 2010, 05:48PM

Posts: 163
Joined: Wed Sep 24 2008, 07:46AM
Registered Member #4406
Thanks for pointing that out dutchbastard!
i tottaly forgot about that :S
i have a backup of the surcepowered data, but that one is really on my "out-of-order" PC.
But the good news is that i scratched together some money and ordered a new PSU just a coupple of hours ago, should arrive on monday.BTW, the replacement of sourcepowered is CGX24, i've already created a section for the imagescript there some time ago and can be accessed at http://forums.cgx24.com/viewforum.php?f=24&nlang=en

Once i can get my hands on the backups i'll sum up all the example snippets in a new thread over there and update all URLs here.

SpiffyTek
Website
Bigfoot
Thu Dec 02 2010, 06:19PM
Posts: 15
Joined: Wed Aug 19 2009, 03:40PM
Registered Member #5359
Ummm i think this must be on integrated on the next version of Lgsl
Website
dutchbastard
Thu Dec 02 2010, 07:09PM
Posts: 19
Joined: Mon Jan 25 2010, 11:53AM
Registered Member #5749
that's great news!
thanks
Website
MadMakz
Sun Dec 05 2010, 04:54PM

Posts: 163
Joined: Wed Sep 24 2008, 07:46AM
Registered Member #4406
A bit later but here's a beta attempt for the DSi details page mod (Standalone + Drupal6 tested only!) based on LGSL 5.8!.
Please test tell me if it isn't working for you (post your install type and CMS version if any)
Prefably to my tracker but posting here is also fine.

Beta download: http://madmakz.com/get/pub/tmp/lgsl/lgsl-dsi-addon-details_page_58-beta.zip
Demo: http://cgx24.com/LGSL/10 (Drupal)

IMPORTANT: i just figured that lgsl_image.php (DSi) MUST HAVE valid SQL credentials (settings) in lgsl_config.php, no matter what type of LGSL installation!
I'll fix this later once i get my hands on the DSi script itself again.

But hey, at least DSi still works fine with LGSL 5.8^^

Laterz

Makz

SpiffyTek
Website
Vinceultras
Tue Dec 21 2010, 11:14AM
Posts: 16
Joined: Mon Dec 20 2010, 08:11PM
Registered Member #6471
I indeed have to install(settle) the lgsl 5.8 and the DSi 1.3, I just have a small concern(marigold) banners does not display

Has you he a modification there to be made

Thank you

website : http://custom-map-mod-cod.fr/lgsl/index.php
Website
KIKOFF
Mon Jan 03 2011, 01:04PM

Posts: 132
Joined: Thu Nov 18 2010, 08:18AM
Registered Member #6411
Hi MadMakz, i set database override in lgsl_config. Still not showing map image and game icon.
I hope the problem of the cms resolved soon.

Installation type: e107 0.7.24 in localhost
LGSL version 5.8
DSi version 1.3

Would also be interesting to truncate the server name and set "..." for final.

Saludos, KIKOFF.

Lo cortez, no quita lo valiente... ahhh... yes e107 Rock
sanken
Tue Jan 04 2011, 07:33AM
Posts: 10
Joined: Thu Dec 09 2010, 04:39PM
Registered Member #6450
Please help me!
http://www.greycube.com/site/e107_plugins/forum/forum_viewtopic.php?12951.0
KIKOFF
Tue Jan 04 2011, 06:01PM

Posts: 132
Joined: Thu Nov 18 2010, 08:18AM
Registered Member #6411
If you like to have shadows on the text, is obtained so:
Duplicate the string of server name, for example.

imagettftext($im,$size3,0,23,13,$text_color1,$text_font0,$string0);
imagettftext($im,$size3,0,22,12,$text_color0,$text_font0,$string0);

Use black color (0,0,0) "$text_color1" in first string and set 1px for X and Y more than the base string.
And white color (255,255,255) "$text_color0" in the second string.

This is all

Lo cortez, no quita lo valiente... ahhh... yes e107 Rock
KIKOFF
Tue Jan 04 2011, 08:09PM

Posts: 132
Joined: Thu Nov 18 2010, 08:18AM
Registered Member #6411
Hello. I have decided to install the SA version of LGSL. To see if that way I could get the image of the map and the game icon in the banner.
My surprise that does not show the 2 pictures ... Maybe there's some problem with the path of the images and PHP version.
Any ideas?

Thanks in advance, KIKOFF

Lo cortez, no quita lo valiente... ahhh... yes e107 Rock
KIKOFF
Thu Jan 06 2011, 01:52PM

Posts: 132
Joined: Thu Nov 18 2010, 08:18AM
Registered Member #6411
Ok i solved my problem with map and icon images... As suspected, was the PHP 5.3.1. I update to PHP 5.3.4 and is done.

Lo cortez, no quita lo valiente... ahhh... yes e107 Rock
Go to page   <<        >>   

Jump:     Back to top


You are not logged in - Click Here To Signup

Username:    Password:   

Mini Buttons

.... © GreyCube.com - Richard Perry - Powered by e107.org